SafeMart Help Center/DIY (Do-It-Yourself)/Frequently Asked DIY or Advantage-Eligible Questions (FAQ)

Adding wireless sensors to an Ademco Vista Series panel

Chris
posted this on September 29, 2011 12:16 PM

Here is how to program wireless sensors into an Ademco Vista Series or SafeWatch panel.

Your alarm system needs to include a wireless receiver or a keypad with a built in receiver in order for your wireless sensors to work. You will also need to know the installer code and have an alpha keypad in order to program the keyfobs.

First make sure the panel is disarmed. Then type in your 4 digit installer code (the default is 4112) followed by 800. You should see this screen.

Installer Code
20

If you do not see this exact screen you either have the wrong installer code or you do not have a programming keypad, hit *99 and do not try to continue.

If you do see that screen then type in *56 and you will enter zone programming.

Set to Confirm?
0=No,1=Yes 0

Push 1 for yes and you will be taken to the zone number screen. Your wireless zones start at zone 9, so type in 09.

Enter Zn Num.
00=Quit 09

Hit * to continue to a summary screen for zone 9.

Zn ZT P RC IN:L
09 00 1 10 RF:-

Hit * to continue to the zone type screen. We will program this sensor as a delay door so type in 01. (See section 3 of the Vista Series manual for the different zone types.)

09 Zone Type
Entry/Exit 1 01

Hit * to continue to the partition screen. Push 1 for partition 1.

09 Partition
1

Hit * to continue to the report code screen. It should look like this, if not type in 01 00.

09 Report Code
1st 01 2nd 00 10

Hit * to continue to the input type screen. Push 3 and you should see this.

09 Input Type
RF Trans. 3

Hit * to continue to the serial number screen.

09 Input S/N  L
Axxx-xxxx 1

Open and close the sensor and the panel should beep and show the serial number. Open and close the sensor again for the loop number. Hit * to continue to the next screen.

Xmit to confirm
Press * to Skip

Open and close the sensor one more time to confirm the serial and loop numbers. This will then take you back to the summary screen.

Zn ZT P RC IN:L
09 01 1 10 RF:1s

Hit * to continue to the next screen.

Program Alpha?
0=No,1=Yes 0

Press 0 for no and you will return to the zone number screen.

Enter Zn Num.
00=Quit 02

From here you can to continue to program any additional zones by repeating the above procedure, or type in 00 to quit and you will see this.

Enter * or #

Type in *99 to exit programming mode and return to the main screen.

 

Comments

User photo
Doug Fundis

Chris, Thanks for the information. I have a Vista-10SE and my original installation and set up guide uses different numbers than you provided. Are your numbers and steps the ones I will use to add new transmitters even though the guide shows different numbers? Just trying to make sure. I do not know the original installer code, the guide shows 4-1-1-1. How would I go about reprogramming the installer code, if that is not the correct code?

September 13, 2012 08:40 PM
User photo
Tc Kelly

Hello Chris. I am really struggling with my Vista 20 P set up I have the 5881EnH wireless controller.  This is where I am currently stuck I followed the instructions to hook up the wireless receiver I have removed all of the Jumper resistors.  I have the proper keypad for programming. From what I could understand for the wireless zones to work properly you have to start with zone nine when programming the system I chose to use zone tend as a starting point. I have have a door sensor.I have followed your instructions to the letter. But still come up with a fault 10 when I try and test the sensor.  I have looked all over the place and just can't find where I am doing something wrong.  any help would be greatly appreciated! thank you very much

January 25, 2013 03:08 AM
User photo
JoeT
SafeMart

Hi Tc, 

A fault just means that the sensor is either open or you have the wrong loop number programmed in. Can you tell us what device you were trying to program as zone number 10?

 

Cheers,

 

Joe

January 25, 2013 07:35 AM
User photo
Tc Kelly

Thank you Chris for getting back to me.  I am trying to set up a door sensor, I have it set up as a number one the enter and exit. I'm not sure what the loop number is that you're referring to.

 

Thank you for your help.

January 25, 2013 11:50 AM
User photo
JoeT
SafeMart

Ademco sensors use "loops" that allow different functions.  Please let me know the part number of sensor you are using. This will start with 58xx, like 5815 or 5816. Thank you in advance.

 

Cheers,

Joe

January 27, 2013 05:43 PM
User photo
Tc Kelly

Yes Joe, it is the 5816 wmwh door sensors.  When i get to the stage of opening and closing the sensor before xmit, it gives the panel a set of codes, then I press * to go on through the rest of it.  I get to the end, then it dings and says fault 10 which is the first wireless on the system.

January 28, 2013 08:30 PM
User photo
JoeT
SafeMart

Ok. I am pretty sure that you have the wrong loop enrolled. 

If you are using the built in reed switch (NOT wiring anything to the 5816WMWH sensor) then you will need to program Loop 2. 

10 Input S/N  L
Axxx-xxxx 2

If you are using a switch that is wired into the wireless transmitter, you will use Loop 1. 

10 Input S/N  L
Axxx-xxxx 1

Please let us know the results. 

Cheers, 

Joe


January 28, 2013 08:44 PM
User photo
Tc Kelly

Ok so I use zone 2 for wireless??  My whole system is to be wireless

January 28, 2013 08:46 PM
User photo
Tc Kelly

Maybe I didn't understand what I read.  There are so many ways of doing these systems.  My plan is to only use wireless if at all possible.   I thought I just had to have wireless on each zone above 9

January 28, 2013 08:51 PM
User photo
JoeT
SafeMart

Use Zones 9 and up for your wireless devices and within that zone use Loop 2  on each 5816. 

A Zone is a device and a Loop is a part of that wireless device. After you transmit the serial number, make sure you have a 2 under the L (see below).

 

Loop_2.png

January 28, 2013 10:05 PM
User photo
Tc Kelly

Ok I got the zone part right.  So all wireless use loop 2?

January 28, 2013 10:24 PM
User photo
JoeT
SafeMart

Just on the following:

5816 Series

5815 Series

5817 Series

And ONLY if you are using the internal reed switch. 

Cheers, 

Joe

January 28, 2013 10:27 PM
User photo
Tc Kelly

LOL good lord!  And I thought this system was gonna be easy! :(

January 28, 2013 10:31 PM
User photo
Tc Kelly

thank you very much for your help Joe! Is the reed switch the tamper switch? Or does that referred to a wireless switch.

January 29, 2013 03:20 AM
User photo
JoeT
SafeMart

Hi Tc, 

The reed switch is what the magnet sits next to and it moves open or closed depending on where the magnet is. 

If the magnet is near it, the reed switch will close. As the magnet moves away, the reed switch opens up. That is how the sensor knows to transmit the "open" signal to the main control panel. 

Cheers, 

Joe

January 29, 2013 04:23 PM
User photo
Tc Kelly

 hello Joe I followed your directions and changed the loop from number one to number two. I've have the same result, fault 10 I can arm the system, and when I open the loop it does set off the timer to disarm the system.  I just don't know what to do, and I know we have to be close.

 

Again I want to thank you for all of your help Joe

TC

January 29, 2013 05:58 PM
User photo
Tc Kelly

Ok.  How about motion sensors? 5800 series? Is that set up the same with a loop 2 option instead of a loop 1?  Also, which option in the manual for zone type is used for motion? Sadly, the manual is very vague with this area of the manual. 

January 31, 2013 08:24 PM
User photo
Tc Kelly

I also checked your videos on the setup, but those are for wired instead of wireless sensors

January 31, 2013 08:26 PM
User photo
JoeT
SafeMart

Hey Tc, 

If you are still getting a fault on Zone 10, can you post the  summary screen for that zone? It is the screen that looks like this:

Zn ZT P RC IN:L
10 00 1 10 RF:-

 

Concerning the 5800 Series motion, that will be Loop 1. Use Zone Type 04 which is "Interior Follower"

Cheers, 

Joe

January 31, 2013 08:39 PM
User photo
Tc Kelly

Yes I will post that when I get home. Thank you again Joe for all of your help!  It's greatly appreciated!

 

January 31, 2013 10:20 PM
User photo
Gabe Torok

Hello Chris,

 

I would appreciate help with adding  a 5814 wireless sensor  to my Vista 20 SE.  I followed your step by step instructions but the sequence changed the following way:

 

After the 4th step I got

ZN ZT P RC IN:L

09 05   - 10   -- -

After the next step I did not get 09 Zone Type, instead I got

09 Report Code  

1st 01 2nd 00 10     which is the same as the previous 4th step

Did the next step (* and  3) and got again the same as above after step 4

Hit * and got

Program Alpha

Selected 0 for No (also tried with 1 for Yes)

Got Enter Zone number

Did 09

got again same as after 4th step above.

 

I would like help in how to get to entering serial number.

 

Thank you,

 

Gabe

August 24, 2013 03:30 PM
User photo
Chris
SafeMart

Gabe,

One thing with the Vista 20SE that will be different is that you want to start with zone 10 for wireless sensors rather than zone 9. Other than that the steps should be close enough to follow along with these directions. Can you try using zone 10 instead of 09 and see if that gives you any trouble?

Chris

August 26, 2013 11:12 AM
User photo
Eric Fisher

How does this process change if you're just replacing a wireless sensor? And is an alpha keypad still required if keyfobs are not needed?

Thank you.

November 21, 2013 05:02 PM
User photo
Freddy Lyvers

Hello,

I am wanting to add a motion detector sensor outside, but believe my I/O board connections are full in my control box.  I have read some of the comments that you guys have out there and am wondering what my options are.

I believe I have a 6150 Keypad and a Vista-20P/Vista-20PSIA control box. 

I also need to add another vibration sensor.

According to an earlier comment I tried the installation code 4112 800 and it did not do anything so I assume I do not have a programmable keypad.

December 27, 2013 09:34 AM
User photo
LiveWatch Security
SafeMart

Freddy,

In order to be able to add any kind of sensor into your system there are a couple things here you will need to get cleared up first.

First is the ''installer'' or ''programming'' code, alot of time it is left at default which is the 4112 however if that doesn't get you into programming then it has been changed. If you enter it in followed by 800 you should see a ''20'' on your screen and this will let you know that you are in programming. You might try to figure out who the previous monitoring company was and contact them...see if they have it. If this was not a system you installed and are familiar with then you might look into replacing it.

Your 6150 keypad will allow you to access programming but you will be ''programming blind'', we never recommend programming anything unless you have a 6160 keypad.

You might look into getting an alarm installer to come out and see if he can get things up and running, he could also get new sensors programmed in for you. Check out myalarminstaller.com to see if there is anyone in your area.

The system you have is pretty complicated, unless you install the system and really know it then maintenance and support can be very challenging. You might look into getting a new wireless system that is just as reliable but also easier to maintain and something you can get free tech support on thru a great company called SafeMart when you sign up with their monitoring services.

 

January 03, 2014 09:26 AM